OpenDNSSEC 2.1.5 released

Published: Tue 05 November 2019

The previous release fixed an important issue, but unfortunately left in a memory leak, which this release fixes. This release of 2.1.5 fixes the memory issue, along with some additional issues primarily relating to minor migration reporting and configuration.

The 2.1.5 release is available immediately from the download site. Installations still on the 1.4 release should really upgrade to this version as it has been tested enough by major players.

Fixes

  • SUPPORT-245: Resolve memory leak in signer introduced in 2.1.4.
  • SUPPORT-244: Don’t require Host and Port to be specified in conf.xml when migrating with a MySQL-based enforcer database backend.
  • Allow for MySQL database to pre-exist when performing a migration, and be a bit more verbose during migration.
  • Fix AllowExtraction tag in configuration file definition.
  • SUPPORT-242: Skip over EDNS cookie option.
  • SUPPORT-240: Prevent exit of enforcer daemon upon interrupted interaction with CLI commands (when having > 1000 zones and aborting a pipe).
  • Correct some error messages.

For OpenDNSSEC 2.1.5 download and additional information:

software update